12 Ноябрь 2019, 21:30:27Последний пользователь: trapatoni
Страниц: [1]   Вниз
  Отправить эту тему  |  Печать  
Автор Тема: AceStream не работает на Windows Server 2016  (Прочитано 707 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Mutronics
Newbie
*
Оффлайн Оффлайн
Сообщений: 3

Email
« : 05 Август 2019, 17:55:25 »

AceStream не работает на Windows Server 2016.
Что пробовал:
Отключал UAC.
Отключал Брандмауэр.
Запускал от имени Администратора..
Запускал в режиме совместимости.
Лог:

2019-08-05 19:39:28,486|MainThread|acestream|init segmenter done: log_path=C:\Users\Администратор.WIN-JSONJD5MMSK\AppData\Roaming\ACEStream\engine\segmenter.log
2019-08-05 19:39:28,486|MainThread|acestream|platform=win32
2019-08-05 19:39:28,486|MainThread|acestream|app=acestream
2019-08-05 19:39:28,486|MainThread|acestream|version=3.1.32 code=3013200 revision=58938e3 date=2018-08-23
2019-08-05 19:39:28,486|MainThread|acestream|use_local_db=True
2019-08-05 19:39:28,487|MainThread|acestream|use_m2crypto=True
2019-08-05 19:39:28,487|MainThread|acestream|is_gui_mode=1
2019-08-05 19:39:28,489|MainThread|acestream|enable debug: 0
2019-08-05 19:39:28,490|MainThread|acestream|get_default_api_version: 2
2019-08-05 19:39:28,605|MainThread|acestream.coreapp|state_dir=u'C:\\Users\\\u0410\u0434\u043c\u0438\u043d\u0438\u0441\u0442\u0440\u0430\u0442\u043e\u0440.WIN-JSONJD5MMSK\\AppData\\Roaming\\.ACEStream'
2019-08-05 19:39:41,132|MainThread|acestream.coreapp|set_debug_from_ui: enabled=0
2019-08-05 19:39:41,132|MainThread|acestream|enable debug: 0
2019-08-05 19:39:41,147|MainThread|acestream.coreapp|cannot load session config, use default
2019-08-05 19:39:41,651|MainThread|acestream.SocketHandler.InterruptSocket|bound on 127.0.0.1:52566
2019-08-05 19:39:41,653|MainThread|acestream.SocketHandler.SocketHandler|failed to bind: addrinfo=[2, None, None, None, ('', 8621)]
2019-08-05 19:39:41,653|MainThread|acestream|failed to init app
Traceback (most recent call last):
  File "core.c", line 346, in
  File "core.c", line 1254, in
  File "core.c", line 1244, in
  File "ACEStream\Core\Session.pyo", line 308, in __init__
  File "ACEStream\Core\APIImplementation\LaunchManyCore.pyo", line 130, in register
  File "ACEStream\Core\BitTornado\RawServer.pyo", line 140, in find_and_bind
  File "ACEStream\Core\BitTornado\SocketHandler.pyo", line 452, in find_and_bind
  File "ACEStream\Core\BitTornado\SocketHandler.pyo", line 422, in bind
error: [Errno 10048] Обычно разрешается только одно использование адреса сокета (протокол/сетевой адрес/порт)
« Последнее редактирование: 05 Август 2019, 18:21:44 от Mutronics » Сообщить модератору   Записан
Benny
Administrator
Hero Member
*****
Оффлайн Оффлайн
Сообщений: 666

Email
« Ответ #1 : 05 Август 2019, 18:51:52 »

Администратор.WIN-JSONJD5MMSK
2019-08-05 19:39:41,653|MainThread|acestream.SocketHandler.SocketHandler|failed to bind: addrinfo=[2, None, None, None, ('', 8621)]
error: [Errno 10048] Обычно разрешается только одно использование адреса сокета (протокол/сетевой адрес/порт)
Имя пользователя желательно сменить на что-то более вменяемое, убедиться, что запускается только один экземпляр движка, ну и с сетью тут явно какие-то траблы - либо не настроено нормально, либо наоборот - слишком сложный случай (много интерфейсов, например, и "нужный" не сконфигурен).
Сообщить модератору   Записан
Mutronics
Newbie
*
Оффлайн Оффлайн
Сообщений: 3

Email
« Ответ #2 : 05 Август 2019, 19:12:48 »

Имя пользователя желательно сменить на что-то более вменяемое, убедиться, что запускается только один экземпляр движка, ну и с сетью тут явно какие-то траблы - либо не настроено нормально, либо наоборот - слишком сложный случай (много интерфейсов, например, и "нужный" не сконфигурен).
Под вменяемым именем тоже не запускается, ни одного экземпляра не запущено, один интерфейс, настроен нормально с сетью проблем нет.
Сообщить модератору   Записан
Benny
Administrator
Hero Member
*****
Оффлайн Оффлайн
Сообщений: 666

Email
« Ответ #3 : 05 Август 2019, 19:18:38 »

один интерфейс, настроен нормально с сетью проблем нет.
Лог-файл говорит об обратном. Если для "ace-engine.exe" попробовать понизить уровень совместимости (до Вин7, например) - что меняется?
Сообщить модератору   Записан
Mutronics
Newbie
*
Оффлайн Оффлайн
Сообщений: 3

Email
« Ответ #4 : 05 Август 2019, 19:40:24 »

один интерфейс, настроен нормально с сетью проблем нет.
Лог-файл говорит об обратном. Если для "ace-engine.exe" попробовать понизить уровень совместимости (до Вин7, например) - что меняется?
Совместимость, как я писал в шапке, ничего не меняет.
В конфиге задал порт 8622 и все заработало, странно но на 6821 у меня ничего нет.
« Последнее редактирование: 05 Август 2019, 19:42:30 от Mutronics » Сообщить модератору   Записан
Страниц: [1]   Вверх
  Отправить эту тему  |  Печать