19 Сентябрь 2019, 18:46:08Последний пользователь: IntTennisCenter
Страниц: 1 [2]   Вниз
  Отправить эту тему  |  Печать  
Автор Тема: Вопрос по бродкастингу  (Прочитано 1646 раз)
0 Пользователей и 1 Гость смотрят эту тему.
CyberMan
Newbie
*
Оффлайн Оффлайн
Сообщений: 4

Email
« Ответ #15 : 10 Сентябрь 2019, 10:55:46 »

Есть хост на дебиане, есть старая документация по запуску трансляции ещё с торрентстрима, но сотаётся вопрос: как добавить более одного трекера в командную строку?

./start_engine ... --trackers url1 url2 url3

или как-то по другому?

И что делать, если я хочу добавить не один десяток трекеров, что бы трансляция была стабильной?
« Последнее редактирование: 10 Сентябрь 2019, 10:59:08 от CyberMan » Сообщить модератору   Записан
Benny
Administrator
Hero Member
*****
Оффлайн Оффлайн
Сообщений: 666

Email
« Ответ #16 : 10 Сентябрь 2019, 20:41:18 »

Несколько трекеров в комстроке задаем через ключ "--tracker", повторяя его для каждого трекера (--tracker "http://tracker.tfile.me:80/announce" --tracker "http://tracker.opentrackr.org:1337/announce" и т.д).

В целом см. https://github.com/acestream/streaming-utils - там и скрипты, и примеры, и оно все более свежее, чем на вики.
Сообщить модератору   Записан
CyberMan
Newbie
*
Оффлайн Оффлайн
Сообщений: 4

Email
« Ответ #17 : 12 Сентябрь 2019, 17:48:56 »

на Ubuntu 18.10 (да и под 18.04 так же) при попытке запустить движок под клиентом пишет:
Цитировать
2019-09-12 17:34:30,714|MainThread|acestream|init segmenter failed
Traceback (most recent call last):
  File "core.c", line 333, in
ImportError: cannot import name pysegmenter

Если я запускаю уже напрямую через консоль HLS_поток  (./start-engine --create-hls-transport с дополнительными параметрами), то вижу сдледуюзщую ошибку:
Цитировать
2019-09-12 17:40:41,093|MainThread|acestream|error during startup
Traceback (most recent call last):
  File "core.c", line 1791, in
  File "core.c", line 706, in
  File "core.c", line 23, in
ImportError: cannot import name pycompat

как можно исправить? Пытаюсь завести последний доступный билд, доступный в вики для 18.04
Сообщить модератору   Записан
Benny
Administrator
Hero Member
*****
Оффлайн Оффлайн
Сообщений: 666

Email
« Ответ #18 : 12 Сентябрь 2019, 18:25:41 »

последний доступный билд, доступный в вики для 18.04
"свежие" билды собраны без ffmpeg/сегментера, с HLS могуть быть проблемы. Нужно либо ждать обновления (планируется скоро), либо использовать 3.1.16.
Сообщить модератору   Записан
Страниц: 1 [2]   Вверх
  Отправить эту тему  |  Печать