14 Декабрь 2019, 11:01:22Последний пользователь: Dudi
Ace Stream Forum » Базовые продукты ACE Stream ( Torrent Stream ) » Анонсы и Релизы  » Тестируем ПО Ace Stream в snap пакете.
Страниц: 1 ... 6 7 [8] 9   Вниз
  Отправить эту тему  |  Печать  
Автор Тема: Тестируем ПО Ace Stream в snap пакете.  (Прочитано 86702 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Benny
Administrator
Hero Member
*****
Оффлайн Оффлайн
Сообщений: 666

Email
« Ответ #105 : 26 Ноябрь 2018, 12:28:03 »

есть ли варианты установки на новую систему но 32 бита?
"официальных" нет. Есть пользовательские моды - https://t.me/AceStreamMOD
Сообщить модератору   Записан
kis-kis-may
Newbie
*
Оффлайн Оффлайн
Сообщений: 33

Email
« Ответ #106 : 26 Ноябрь 2018, 12:39:56 »

да хоть какие-нибудь.
нужно на старый ноут с 1 гигом памяти.
Сообщить модератору   Записан
Benny
Administrator
Hero Member
*****
Оффлайн Оффлайн
Сообщений: 666

Email
« Ответ #107 : 26 Ноябрь 2018, 12:49:07 »

нужно на старый ноут с 1 гигом памяти.
а зачем на этот "старый ноут" ставить 18.04? 12.04 (и сразу х64, т.к "экономия" от i386 сомнительна), и тогда ставится "какой-нибудь" Ace Stream из официального репозитория.
Сообщить модератору   Записан
kis-kis-may
Newbie
*
Оффлайн Оффлайн
Сообщений: 33

Email
« Ответ #108 : 26 Ноябрь 2018, 13:03:37 »

ставлю из-за поддержки. из нетинстала. получил 120мб после загрузки системы на 32битах. на 64 будет раза в 2 больше а еще софт нужен.
пока вижу два варианта. либо устанавливать движок в вайне+нативный влк. либо извлечь список уже установленных пакетов и установить заново в 64 битной системе.
жалко только проделанной работы уже настроенной ос.
Сообщить модератору   Записан
Benny
Administrator
Hero Member
*****
Оффлайн Оффлайн
Сообщений: 666

Email
« Ответ #109 : 26 Ноябрь 2018, 13:19:03 »

либо устанавливать движок в вайне
Это извращение  - https://4pda.ru/forum/dl/post/13887120/acestream_3.1.33_x86_webUI.tar.gz (или см. ссылку на телеграм канал ниже) - уже все придумано, х86 версия запускается в systemd или chroot контейнере.  Это, конечно, тоже "извращение", но в меньшей степени =)
Сообщить модератору   Записан
kis-kis-may
Newbie
*
Оффлайн Оффлайн
Сообщений: 33

Email
« Ответ #110 : 28 Ноябрь 2018, 18:51:19 »

все же переустановил систему в 64 бита. после установки занято 180мб. в среднем на 10-15% больше памяти уходит.
вообщем допустимо. установил снап. все работает.
расстроило только что в плеере нельзя выставить аппаратное ускорение видео. по-умолчанию дизэйбл. пробую установить  va-api а он пишет что настройки сохранить не получается. как быть? экспортировать поток в другой плеер? или все же есть способы настроить родной плеер?
Сообщить модератору   Записан
vasilisc
Newbie
*
Оффлайн Оффлайн
Сообщений: 46

Email
« Ответ #111 : 04 Декабрь 2018, 13:26:05 »

Прошло много времени, а разработчики никак не актуализировали своё детище и это печально. Через репозитории deb доступна старая версия плеера, основанная на VLC 2.1.4 и только для старых версий Ubuntu (12.04 и 14.04). Из git проекта я взял исходники плеера, чьи патчи нормально подходят к vlc 2.1.5 и всё! Стабильность плеера остаётся ужасной. Плеер по-прежнему падает при нажатии Вперёд-Назад.

В свете таких событий и что пользователи просят добавить интерфейс removable-media для изменения расположения папки кэша, выпущу новую версию snap пакета, но внутри, к сожалению, оставляю все версии прежними (engine и player). Сделаю косметические улучшения и залью новую версию.

Данную ветку перечитал заново и выписал себе пункты для проработки. Если есть какие-либо ещё пожелания - пишите.
« Последнее редактирование: 04 Декабрь 2018, 13:41:05 от vasilisc » Сообщить модератору   Записан
vasilisc
Newbie
*
Оффлайн Оффлайн
Сообщений: 46

Email
« Ответ #112 : 04 Декабрь 2018, 13:57:42 »

Доброго времени суток!

Система openSUSE Leap 42.3. Не выводит звук через Alsa, попросту отсутствует звук, сыпя ошибками о том, что аудиоустройство использовать нельзя. PulseAudio отключен. Скажу сразу, что ставил без "бета" ключа, но и там наблюдалось тоже самое. Есть соображения, как все таки заставить его выводить звук через Alsa?

P.S. Выхлоп терминала мало чем полезен, пока я в ручную не прописал в конфиге, чтобы он выводил через Alsa, жаловался на то, что сервер PulseAudio отключен\недоступен.

P.S.S. asoundrc настроен на воспроизведение из нескольких источников сразу.
Есть интерфейс alsa, который я лично не тестировал и он относится к НЕ автоподключаемым. Попробую, но не обещаю.
Подробно
https://docs.ubuntu.com/core/en/reference/interfaces/
Сообщить модератору   Записан
Benny
Administrator
Hero Member
*****
Оффлайн Оффлайн
Сообщений: 666

Email
« Ответ #113 : 04 Декабрь 2018, 14:10:15 »

разработчики никак не актуализировали своё детище и это печально.
да, свежая версия движка под Линукс "опаздывает" уже на полгода, и "печально" это немного не то слово =)
патчи нормально подходят к vlc 2.1.5 и всё! Стабильность плеера остаётся ужасной. Плеер по-прежнему падает при нажатии Вперёд-Назад
забудьте вы уже про встроенный плеер. Выбор/модификация VLC на старте проекта был обусловлен двумя основными моментами - на то время это был чуть ли не единственный /открытый/ плеер, адекватно работающий с сетевыми потоками, плюс у него уже были NPAPI плагины для браузеров.

На сегодняшний день, когда от NPAPI отказались все сколь-нибудь популярные браузеры, для пользователя нет смысла в "оригинальном" AcePlayer HD от слова "совсем" - используйте любой другой плеер, хоть тот же VLC свежих версий. Основные проблемы со сторонними плеерами, касаемые мультифайловых торрентов и т.п решены на уровне движка - при запросе подобного файла движок вернет m3u плейлист, где серии/треки будут в виде отдельных позиций.
Что же касается запуска этого самого "стороннего плеера" по клику на acestream:// ссылку или .torrent файл, то лично я у себя использую (даже под виндой) простенький bash-скрипт (см. вложение).

Итоги подведем (с) ЛП - полностью мы еще не отказались от идеи использовать "встроенный" плеер в сборках для Виндовс (и, в меньшей степени - Линукс), но когда он обновится, и будет ли он на базе libVLC или чего-то другого - на текущий момент неизвестно.

* aceplay.sh (1.03 кБ - загружено 375 раз.)
Сообщить модератору   Записан
vasilisc
Newbie
*
Оффлайн Оффлайн
Сообщений: 46

Email
« Ответ #114 : 11 Декабрь 2018, 14:46:09 »

Можно ли переопределить местоположение файла acestream.conf?
Прочёл
http://wiki.acestream.org/wiki/index.php/Configuration_Files
подумал что движок на питоне написан ради кроссплатформенности и, возможно, пути в Linux похожи на пример в MS Windows, но strace не показывает что есть обращение за файлами аля
~/.ACEStream/engine/acestream.conf
~/.ACEStream/engine/acestream_user.conf


Сообщить модератору   Записан
Benny
Administrator
Hero Member
*****
Оффлайн Оффлайн
Сообщений: 666

Email
« Ответ #115 : 11 Декабрь 2018, 15:04:45 »

Можно ли переопределить местоположение файла acestream.conf?
можно, конструкцией вида "@/path/to/file.conf". Для запуска из текущего каталога "start_engine --client-console @my.conf"

PS Обновили вики заодно.
Сообщить модератору   Записан
j.cryton
Newbie
*
Оффлайн Оффлайн
Сообщений: 9

Email
« Ответ #116 : 07 Июнь 2019, 00:44:22 »

Какая топовая версия AceStreamPlayer(VLC)? Где впредь лучше брать готовые бинарные сборки под платформу amd64? Пока не готов компилить из исходников.

Here:
https://github.com/Jcryton/acestreamplayer-2.1/releases
https://github.com/Jcryton/acestreamplayer-2.2/releases

Прошло много времени, а разработчики никак не актуализировали своё детище и это печально. Через репозитории deb доступна старая версия плеера, основанная на VLC 2.1.4 и только для старых версий Ubuntu (12.04 и 14.04). Из git проекта я взял исходники плеера, чьи патчи нормально подходят к vlc 2.1.5 и всё! Стабильность плеера остаётся ужасной. Плеер по-прежнему падает при нажатии Вперёд-Назад.

В свете таких событий и что пользователи просят добавить интерфейс removable-media для изменения расположения папки кэша, выпущу новую версию snap пакета, но внутри, к сожалению, оставляю все версии прежними (engine и player). Сделаю косметические улучшения и залью новую версию.

Данную ветку перечитал заново и выписал себе пункты для проработки. Если есть какие-либо ещё пожелания - пишите.

Try it:
https://github.com/Jcryton/acestreamplayer-2.1
https://github.com/Jcryton/acestreamplayer-2.2

This is stuff... AS IS.
Good Luck.
Сообщить модератору   Записан
vasilisc
Newbie
*
Оффлайн Оффлайн
Сообщений: 46

Email
« Ответ #117 : 16 Ноябрь 2019, 09:30:29 »

Залил новую версию snap пакета - acestreamplayer_3.1.49-snap1_amd64.snap. Заодно сменил нумерацию пакета вслед за нумерацией движка (engine) - version=3.1.49 code=3014900 revision=dc5eac3 date=2019-07-15

Внутри пакета VLC media player 2.2.8.1 Ace Stream (revision 2.2.8-13-g91767ab) от разработчика JCryton. Спасибо ему за адаптацию патчей к новой версии VLC! Плеер реально стал стабилен в целом, но падает если ему передать в терминале параметр в виде ссылки acestream:// . Так как в пакете давно присутствует MPV и скрипт-обёртка-наработка от Benny, то сделал acestreamplayer.mpv обработчиком ссылок acestream:// и можете вызывать в терминале
acestreamplay.mpv acestream://123456789

Теперь доступно аппаратное ускорение видеопросмотра. Современные кодеки и их варианты реально поддерживаются (h265-10bit и т.д).

Установить с нуля программу acestreamplayer можно через Gnome Software и/или KDE Discover или в Терминале
sudo snap install acestreamplayer

У кого установлена старая версия, она скоро автоматически обновится. Форсировано можно
sudo snap refresh

Помощь к движку
acestreamplayer.engine --help

Помощь к плееру
acestreamplayer --help

Помощь к обёртке-скрипту для MPV (наработка Benny)
acestreamplayer.mpv --help

При проблемах
acestreamplayer -vv
« Последнее редактирование: 09 Декабрь 2019, 07:03:11 от vasilisc » Сообщить модератору   Записан
akelgurrr
Newbie
*
Оффлайн Оффлайн
Сообщений: 3

Email
« Ответ #118 : 07 Декабрь 2019, 08:32:55 »

Здравствуйте! После переустановки дебиана 10 перестал запускаться AceStream как движок, так и плееры.
Ставил с нуля через  sudo snap install acestreamplayer.
Уже тогда обратил на сообщение  - INFO snap "acestreamplayer" has bad plugs or slots: (unknown interface "audio-playback")

Но программа установилась. При запуске движка, ACE mpv или Ace Player HD ничего не происходит.  В процессах висит run.sh

Запустив acestreamplayer с ключом -vvv запуск движка останавливается после строк:  sh: 1: /bin/netstat : not found
                                                                                                                                                 sh: 1: /sbin/ifconfig: not found

Дальше ничего не происходит. Ставил пакет net-tools, но не помогло.
До этого пользовался Acestream v 3.02 она работала на Дебиане 10. Заметил, что обновился Acestream лишь по новому значку Ace Mpv! Но что странно, через mpv ничего не запускалось! А через Ace Player HD всё работало как и раньше! Знал бы не переустанавливал бы систему!  Да и еще, устанавливал в лайв режиме дебиана КДЕ acestream такая же ошибка с unknown interface audio-playback и ничего не запускалось.
В общем как-то так . Буду благодарен любой помощи
« Последнее редактирование: 07 Декабрь 2019, 08:38:09 от akelgurrr » Сообщить модератору   Записан
vasilisc
Newbie
*
Оффлайн Оффлайн
Сообщений: 46

Email
« Ответ #119 : 09 Декабрь 2019, 06:57:44 »

перестал запускаться AceStream как движок, так и плееры... Буду благодарен любой помощи
дайте
apt-cache policy snapdsnap list | grep core
Сообщить модератору   Записан
Страниц: 1 ... 6 7 [8] 9   Вверх
  Отправить эту тему  |  Печать