18 Ноябрь 2018, 10:20:03Последний пользователь: Lightman
Ace Stream Forum » Базовые продукты ACE Stream ( Torrent Stream ) » Анонсы и Релизы  » Тестируем ПО Ace Stream в snap пакете.
Страниц: 1 ... 5 6 [7]   Вниз
  Отправить эту тему  |  Печать  
Автор Тема: Тестируем ПО Ace Stream в snap пакете.  (Прочитано 45806 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Benny
Administrator
Hero Member
*****
Оффлайн Оффлайн
Сообщений: 666

Email
« Ответ #90 : 23 Декабрь 2017, 04:49:23 »

как убрать из запуска параметр --no-playlist-tree?
Если почитать тему внимательно, то станет ясно, что эта опция автором сборки добавлена не зря.
Сообщить модератору   Записан
NiSa
Newbie
*
Оффлайн Оффлайн
Сообщений: 5

Email
« Ответ #91 : 23 Декабрь 2017, 04:54:11 »

как убрать из запуска параметр --no-playlist-tree?
Если почитать тему внимательно, то станет ясно, что эта опция автором сборки добавлена не зря.

Я прочитал всё от и до.Я ж не спросил зачем это добавили,я спросил как это убрать.Буду благодарен за ответ по теме.
Сообщить модератору   Записан
Benny
Administrator
Hero Member
*****
Оффлайн Оффлайн
Сообщений: 666

Email
« Ответ #92 : 23 Декабрь 2017, 06:23:08 »

Я прочитал всё от и до.
Правда? Тогда не очень понятно, откуда родился вопрос про "убрать" - т.к если убрать этот ключ, то плеер просто "неработоспособен" с плейлистами.
Буду благодарен за ответ по теме.
Без пересборки snap-пакета - скорее всего никак, хотя этот момент лучше уточнять у автора сборки (его контакты есть в первом посте).
Сообщить модератору   Записан
NiSa
Newbie
*
Оффлайн Оффлайн
Сообщений: 5

Email
« Ответ #93 : 23 Декабрь 2017, 09:40:17 »

Тогда не очень понятно, откуда родился вопрос про "убрать"

У меня "своя атмосфера".я читал про всё это.Я ж говорю,что так надо:)Спасибо за ответ :)
Сообщить модератору   Записан
NiSa
Newbie
*
Оффлайн Оффлайн
Сообщений: 5

Email
« Ответ #94 : 23 Декабрь 2017, 10:55:46 »

Пока решил только так.стартовать acestreamplayer --playlist-tree,тогда параметр который вшит не пашет и я получаю нужное дерево.У меня так работает всё норм.НО!я юзаю только для просмотра ттв из плейлиста и каналы переключаю не "вперед-назад",а кликом по нужному каналу и всё пашет норм.Пока только вижу такое решение (для себя) создать десктоп файл с нужным параметром(что бы не тыцкать каждый раз терминал).А там посмотрим.
Сообщить модератору   Записан
ururu
Newbie
*
Оффлайн Оффлайн
Сообщений: 1

Email
« Ответ #95 : 23 Декабрь 2017, 12:16:26 »

Доброго всем дня.
Стоял у меня Ace Stream ещё на Убунту 14.04, пару лет назад установленный. И всё бы хорошо, но время от времени пропадал звук в трансляциях. Тут я как раз на Убунту 17.10 решил перейти, заодно обновлю, думаю, Ace Stream, глюк пропадёт. Обновил систему, поставил snap пакет. Пакет ставил без --beta, так как увидел в теме сообщение, что автор запилил стабильный пакет. Запускаю. Плеер запускается с интерфейсом, как в Windows 95, в консоли пишет:

ururu@ururu-MS-7721:~$ acestreamplayer
Use --help if you need
Use -vvv for debug
Details http://forum.torrentstream.org/index.php?topic=12094.0
AceStreamEngine run with --client-gtk
Gtk-Message: Failed to load module "unity-gtk-module"
Gtk-Message: Failed to load module "gail"
Gtk-Message: Failed to load module "atk-bridge"
sh: 1: /bin/netstat: Permission denied
sh: 1: /sbin/ifconfig: Permission denied
AceStreamPlayer run with
--play-and-stop --no-playlist-tree --no-qt-recentplay

VLC media player 2.1.4 Ace Stream (revision 2.1.4-0-g2a072be)
[0x188cc18] main interface error: no suitable interface module
[0x16fbc48] main libvlc error: interface "globalhotkeys,none" initialization failed
[0x188d018] dbus interface error: Error requesting service name org.mpris.MediaPlayer2.vlc.instance11521: Connection ":1.171" is not allowed to own the service "org.mpris.MediaPlayer2.vlc.instance11521" due to AppArmor policy
[0x188d018] main interface error: no suitable interface module
[0x16fbc48] main libvlc error: interface "dbus,none" initialization failed
[0x16fbc48] main libvlc: Запуск vlc с интерфейсом по умолчанию. Используйте 'cvlc' для запуска vlc без интерфейса.
Qt: Session management error: None of the authentication protocols specified are supported


Но это и фиг бы с ним, я его запускаю не чтобы на кнопочки любоваться. Но вот звук в трансляциях так и пропадает время от времени. Симптомы: трансляция начинает тормозить, изображение идёт цветными квадратиками, проходит несколько секунд и видео снова идёт нормально, а звука нет. Если нажать на Стоп и запустить трансляцию заново, звук появляется. Что это за нафиг и как побороть?

Кусок лога (точно поймать что пишется в лог при пропадании звука не получилось, но это где-то здесь):

[0x7fea40005e28] main input error: ES_OUT_SET_(GROUP_)PCR  is called too late (pts_delay increased to 5522 ms)
[0x7fea40005e28] main input error: ES_OUT_RESET_PCR called
[h264 @ 0x7fea1400e5e0] reference picture missing during reorder
[h264 @ 0x7fea1400e5e0] reference picture missing during reorder
[h264 @ 0x7fea1400e5e0] reference picture missing during reorder
[h264 @ 0x7fea1400e5e0] Missing reference picture
[h264 @ 0x7fea1400e5e0] Missing reference picture
[h264 @ 0x7fea1400e5e0] Missing reference picture
[h264 @ 0x7fea1400ee60] mmco: unref short failure
[h264 @ 0x7fea1400f2a0] reference picture missing during reorder
[h264 @ 0x7fea1400f2a0] reference picture missing during reorder
[h264 @ 0x7fea1400f2a0] Missing reference picture
[h264 @ 0x7fea1400f2a0] Missing reference picture
[h264 @ 0x7fea1400e5e0] mmco: unref short failure
[h264 @ 0x7fea1400e5e0] mmco: unref short failure
[h264 @ 0x7fea1400e5e0] reference picture missing during reorder
[h264 @ 0x7fea1400e5e0] Missing reference picture
[h264 @ 0x7fea1400ea20] reference picture missing during reorder
[h264 @ 0x7fea1400ea20] reference picture missing during reorder
[h264 @ 0x7fea1400ea20] Missing reference picture
[h264 @ 0x7fea1400ea20] Missing reference picture
[h264 @ 0x7fea1400ee60] mmco: unref short failure
[h264 @ 0x7fea1400ee60] reference picture missing during reorder
[h264 @ 0x7fea1400ee60] Missing reference picture
[h264 @ 0x7fea1400e5e0] mmco: unref short failure
[h264 @ 0x7fea1400ea20] reference picture missing during reorder
[h264 @ 0x7fea1400ea20] Missing reference picture
[h264 @ 0x7fea1400ee60] reference picture missing during reorder
[h264 @ 0x7fea1400ee60] reference picture missing during reorder
[h264 @ 0x7fea1400ee60] Missing reference picture
[h264 @ 0x7fea1400ee60] Missing reference picture
[h264 @ 0x7fea1400f2a0] number of reference frames (0+6) exceeds max (4; probably corrupt input), discarding one
[h264 @ 0x7fea1400f2a0] reference picture missing during reorder
[h264 @ 0x7fea1400f2a0] Missing reference picture
[h264 @ 0x7fea1400e5e0] mmco: unref short failure
[h264 @ 0x7fea1400e5e0] reference picture missing during reorder
[h264 @ 0x7fea1400e5e0] Missing reference picture
[h264 @ 0x7fea1400ea20] reference picture missing during reorder
[h264 @ 0x7fea1400ea20] reference picture missing during reorder
[h264 @ 0x7fea1400ea20] Missing reference picture
[h264 @ 0x7fea1400ea20] Missing reference picture
[h264 @ 0x7fea1400ee60] number of reference frames (0+6) exceeds max (4; probably corrupt input), discarding one
[h264 @ 0x7fea1400ee60] reference picture missing during reorder
[h264 @ 0x7fea1400ee60] Missing reference picture
[h264 @ 0x7fea1400e5e0] reference picture missing during reorder
[h264 @ 0x7fea1400e5e0] reference picture missing during reorder
[h264 @ 0x7fea1400e5e0] Missing reference picture
[h264 @ 0x7fea1400e5e0] Missing reference picture
[h264 @ 0x7fea1400ea20] number of reference frames (0+6) exceeds max (4; probably corrupt input), discarding one
[h264 @ 0x7fea1400ee60] mmco: unref short failure
[h264 @ 0x7fea1400f2a0] reference picture missing during reorder
[h264 @ 0x7fea1400f2a0] Missing reference picture
[h264 @ 0x7fea1400e5e0] number of reference frames (0+6) exceeds max (4; probably corrupt input), discarding one
[h264 @ 0x7fea1400e5e0] reference picture missing during reorder
[h264 @ 0x7fea1400e5e0] Missing reference picture
[h264 @ 0x7fea1400ea20] mmco: unref short failure
[h264 @ 0x7fea1400ee60] reference picture missing during reorder
[h264 @ 0x7fea1400ee60] reference picture missing during reorder
[h264 @ 0x7fea1400ee60] Missing reference picture
[h264 @ 0x7fea1400ee60] Missing reference picture
[h264 @ 0x7fea1400f2a0] number of reference frames (0+6) exceeds max (4; probably corrupt input), discarding one
[h264 @ 0x7fea1400e5e0] mmco: unref short failure
[h264 @ 0x7fea1400ee60] mmco: unref short failure
[h264 @ 0x7fea1400ee60] mmco: unref short failure
[h264 @ 0x7fea1400ee60] number of reference frames (0+6) exceeds max (4; probably corrupt input), discarding one
[h264 @ 0x7fea1400e5e0] mmco: unref short failure
Сообщить модератору   Записан
Benny
Administrator
Hero Member
*****
Оффлайн Оффлайн
Сообщений: 666

Email
« Ответ #96 : 23 Декабрь 2017, 15:57:19 »

Но вот звук в трансляциях так и пропадает время от времени.
Собственно, если предположить, что виноват в этом Ace Player (VLC), то ничего удивительного нет - и в старой 14.04, и в snap-пакете они одинаковы.

Если основная цель - просмотр ТВ трансляций, и не нужна интеграция плеера и движка, то просто запускайте движок (из snap-пакета, или из tar.gz дистрибутива), и пробуйте открывать плейлисты (с той же помойки) в любом плеере.

PS NiSa, это же касается проблемы с плейлистами. Устанавливаем актуальную версию VLC, и открываем плейлист там - работает, проверено:


* aces.png (85.76 кБ, 1127x717 - просмотрено 609 раз.)
Сообщить модератору   Записан
NiSa
Newbie
*
Оффлайн Оффлайн
Сообщений: 5

Email
« Ответ #97 : 23 Декабрь 2017, 19:10:13 »

А вот про НЕ бета пакет я и не увидел нигде.прикольно:)Но ка бы и бетка пашет норм:)
Сообщить модератору   Записан
Organarh
Newbie
*
Оффлайн Оффлайн
Сообщений: 4

Email
« Ответ #98 : 17 Январь 2018, 14:36:51 »

  :'( Manjaro 17.1.1 xfce x64
В манжаро 17.03 ставил:sudo pacman -S snapd>sudo systemctl enable --now snapd.socket>sudo snap install acestreamplayer всё нармально запускалось.После чистой установки манжаро 17.1.1 acestreamplayer через снап ставится но не запускается.Что делать может кто сталкивался???
Сообщить модератору   Записан
igor nikolaevich
Newbie
*
Оффлайн Оффлайн
Сообщений: 6

Email
« Ответ #99 : 29 Январь 2018, 05:52:38 »

Подскажите, возможно ли запустить это на (с линуксом особо не знаком, надеюсь подскажите):

Linux version 3.4.112 (padavan@hms) (gcc version 4.4.7 (GCC) ) #1 Sun Jul 10 13:53:24 MSK 2016
-------
Linux RT-AC51U 3.4.112 #1 Sun Jul 10 13:53:24 MSK 2016 mips GNU/Linux
-------

Хочу запустить движок на роутере RT-AC51U :)
RemoteFork и acehttp удалось поднять

Цитировать
/opt/share/nginx/html/aceproxy # acehttp.py [LINE:620 ]# DEBUG [28.01 18:34:33] Plugin loaded: Torrenttelik
acehttp.py [LINE:620 ]# DEBUG [28.01 18:34:33] Plugin loaded: Torrenttv
acehttp.py [LINE:620 ]# DEBUG [28.01 18:34:33] Plugin loaded: P2pproxy
acehttp.py [LINE:620 ]# DEBUG [28.01 18:34:33] Plugin loaded: Torrentfilms
acehttp.py [LINE:879 ]# INFO [28.01 18:34:34] Using gevent 1.2.2
acehttp.py [LINE:880 ]# INFO [28.01 18:34:34] Using psutil 5.4.2
acehttp.py [LINE:883 ]# INFO [28.01 18:34:34] Server started.
Или может быть есть исходники движка, который можно пересобрать под этот линукс?
« Последнее редактирование: 29 Январь 2018, 06:06:05 от igor nikolaevich » Сообщить модератору   Записан
Dorik1972
Jr. Member
**
Оффлайн Оффлайн
Сообщений: 58

Email
« Ответ #100 : 29 Январь 2018, 08:37:27 »

Linux version 3.4.112 (padavan@hms) (gcc version 4.4.7 (GCC) ) #1 Sun Jul 10 13:53:24 MSK 2016
-------
Linux RT-AC51U 3.4.112 #1 Sun Jul 10 13:53:24 MSK 2016 mips GNU/Linux
Движка под mipsel нет и скорее всего не будет  ;) Я выкладывал инструкцию как на проксе запущенной на роутере "пользвоать" удаленные движки - http://mytalks.ru/index.php?topic=4506.msg77261;topicseen#msg77261 + прокся уже есть ГОРАЗДО свежее ... В общем добро пожаловать в клуб  ;D
Сообщить модератору   Записан
Benny
Administrator
Hero Member
*****
Оффлайн Оффлайн
Сообщений: 666

Email
« Ответ #101 : 26 Март 2018, 20:59:45 »

[0x1905f98] pulse audio output error: PulseAudio server connection failure: Connection refused
Не ленитесь читать эту тему/использовать поиск -  http://forum.torrentstream.org/index.php?topic=12094.msg25334#msg25334
Сообщить модератору   Записан
Organarh
Newbie
*
Оффлайн Оффлайн
Сообщений: 4

Email
« Ответ #102 : 02 Июнь 2018, 17:12:26 »

После обновления появилась реклама.Смотреть  стрим практически невозможно после буферизации стрим не запускается а если поставить на паузу и подожтать пять-десять секнд плеер просто пропадает.Что делать???(галочка влючить проигрование развлекательных роликов ..... выключена).
Сообщить модератору   Записан
Dorik1972
Jr. Member
**
Оффлайн Оффлайн
Сообщений: 58

Email
« Ответ #103 : 05 Июнь 2018, 07:34:15 »

Осьо Вам на "разрыв" и критику :) - http://mytalks.ru/index.php?topic=4506.msg82484#msg82484  ;D Вроде как тоже в контейнере ... Извините , ели не по теме запостил ...
Сообщить модератору   Записан
Страниц: 1 ... 5 6 [7]   Вверх
  Отправить эту тему  |  Печать